Debian update for lib3mf

This security advisory describes one high risk vulnerability.


1) Use-after-free


Risk: High


CVSSv3.1: 7.1 [CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]


CVE-ID: CVE-2021-21772


CWE-ID: CWE-416 - Use After Free


Exploit availability: No


Description

The vulnerability allows a remote attacker to compromise vulnerable system.


The vulnerability exists due to a use-after-free error in the NMR::COpcPackageReader::releaseZIP() functionality. A remote attacker can use a specially crafted 3MF file and execute arbitrary code on the target system.


Successful exploitation of the vulnerability may allow an attacker to compromise vulnerable system.


Mitigation

Update lib3mf package to version 1.8.1+ds-3+deb10u1.


Vulnerable software versions

lib3mf (Debian package): 1.8.0+ds-1, 1.8.1+ds, 1.8.1+ds-1, 1.8.1+ds-2, 1.8.1+ds-3, 1.8.1+ds-3.1


CPE
External links

https://www.debian.org/security/2021/dsa-4887


Q & A


Can this vulnerability be exploited remotely?


Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.


Is there known malware, which exploits this vulnerability?


No. We are not aware of malware exploiting this vulnerability.