Critical flaw opens Palo Alto Networks firewalls and VPN appliances to attack, patch ASAP! - Help Net Security

Critical flaw opens Palo Alto Networks firewalls and VPN appliances to attack, patch ASAP! - Help Net Security

Palo Alto Networks has patched a critical and easily exploitable vulnerability (CVE-2020-2021) affecting PAN-OS, the custom operating system running on its next generation firewalls and enterprise VPN appliances, and is urging users to update to a fixed version as soon as possible.


The US Cyber Command has echoed the call for immediate action, saying that nation-state-backed attackers are likely to try to exploit it soon.



Please patch all devices affected by CVE-2020-2021 immediately, especially if SAML is in use. Foreign APTs will likely attempt exploit soon. We appreciate @PaloAltoNtwks’ proactive response to this vulnerability.


https://t.co/WwJdil5X0F


— USCYBERCOM Cybersecurity Alert (@CNMF_CyberAlert) June 29, 2020


About the vulnerability (CVE-2020-2021)


CVE-2020-2021 is an authentication bypass vulnerability that could allow unauthenticated, remote attackers to gain access to and control of the vulnerable devices, change their settings, change access control policies, turn them off, etc.


Affected PAN-OS versions include versions earlier than PAN-OS 9.1.3; PAN-OS 9.0 versions earlier than PAN-OS 9.0.9; PAN-OS 8.1 versions earlier than PAN-OS 8.1.15, and all versions of PAN-OS 8.0 (EOL). Version 7.1 is not affected.


Also, the vulnerability is exploitable only if:


The device is configured to use SAML authentication with single sign-on (SSO) for access management, and
The “Validate Identity Provider Certificate” option is disabled (unchecked) in the SAML Identity Provider Server Profile


“Resources that can be protected by SAML-based single sign-on (SSO) authentication are GlobalProtect Gateway, GlobalProtect Portal, Gl ..