Cisco Patches Severe Flaws in Network Management Products, Switches

Cisco this week released patches for over a dozen vulnerabilities affecting multiple products, including three critical bugs impacting its ACI Multi-Site Orchestrator, Application Services Engine, and NX-OS software.


The most severe of these issues is a flaw in an API endpoint of ACI Multi-Site Orchestrator (MSO), which could allow a remote attacker to bypass authentication. The vulnerability is tracked as CVE-2021-1388 and features a CVSS score of 10.


Due to the improper validation of tokens, an attacker could send crafted requests to receive a token with administrator-level privileges that they could then use to authenticate to the API on affected MSO devices.


According to Cisco, ACI MSO running software version 3.0 is vulnerable, but only if deployed on an Application Services Engine (it can also be deployed as VMs on a hypervisor).


Cisco also addressed two unauthorized access bugs in Application Services Engine, namely CVE-2021-1393 and CVE-2021-1396, but only the former has a severity rating of critical (CVSS score 9.8). An attacker could exploit these bugs to gain privileged access to host-level operations, access device information, modify configurations, or create diagnostic files.


Due to insufficient access controls in the Data Network, an attacker could access a privileged service by exploiting CVE-2021-1393, or could access a specific API when exploiting CVE-2021-1396. Only Application Services Engine release 1.1 is vulnerable and no workarounds exist for these bugs.


Also featuring a CVSS score of 9.8, the third critical flaw that Cisco patched this week (CVE-2021-1361) affects Nexus 3000 and Nexus 9000 series switches. Affecting the NX-OS software, the issue could be exploited remotely to manipulate arbitrary files with root privileges, without authentication.


“A successful exploit could allow the attacker to create, delete, or overwrite arbitrary files, including sensitive files th ..